Results 1 to 7 of 7

Thread: K-Plane pump issue

  1. #1
    PBN Charter Member
    Join Date
    Nov 2013
    Location
    New England
    Posts
    57

    Ignore User

    K-Plane pump issue

    On my new to me boat I have 280 K-Planes and I have one doing the weirdest thing. The Port side pump works and sounds as it should. The Starboard one pumps so fast that the tab is difficult to control. The pump seems to spin at double the speed as the Port one. The tab also moves at twice the speed. A simple tap of the switch will move it at least 1 or 2 number settings on the indicator. I'm kind of stumped on this. Anyone come across this before? Someone had suggested that the tab pump was inadvertently switched with a drive trim pump but this is not the case. It clearly says Tab on the pump. Both pumps are running the same fluids. Anyone have any ideas?
    Thanks

  2. #2
    PBN User Drew's Avatar
    Join Date
    Jun 2014
    Location
    Long Island new york
    Posts
    419
    Hydrosteam, velocity, fountain


    Ignore User
    Switch pump motors from each side and see if it is the motor

  3. #3
    PBN Charter Member 92nsx's Avatar
    Join Date
    Jul 2014
    Location
    Clearwater, Mn
    Posts
    1,951
    33 Outlaw, 502 Mag's


    Ignore User
    Once you find out report back. I would like to speed my pumps up . Is the boat new to you, boat has always been like this, or this just started to happen in the last week?
    Few things come to mind.

    My self, what I always run into on boats is bad/loose grounds and under sized cables. But lets say all the wire is of ABYC standards

    Do the 2 motors "sound" like there spinning about the same speed? There is a screen on the pick up inside the tank. They can become clogged over time ( this would be for the slower pump)

    Ground wire on pump or engine block is loose or corrosion
    The switch contacts have corrosion on them limiting current draw
    Contacts on the pump/motor (green blue red wires) have corrosion at the contacts. ( or the solenoid )

    Has it been like this since you have owned the boat? Maybe someone in the past replaced the motor/pump? 12 and 24 volt systems. One of the pumps/ motor could be a 24 volt motor only running on a 12 volt setup?


    Now lets say it is WAY to fast....... That Is a good question. Never seen that issue. They always slow down. Never speed up. Do you have it wired to 24 volt, hahaha.
    Last edited by 92nsx; 4 Weeks Ago at 06:47 AM.

  4. #4
    PBN Charter Member
    Join Date
    Nov 2013
    Location
    New England
    Posts
    57

    Ignore User
    I can tell it is turning too fast. The slow one operates and sounds just like all the other boats I've owned with K-Planes. The fast one sounds like its turning at twice the speed of the slow one. This isn't a case where the slow one is slowing down from normal speed. I'm pretty crafty but this one has me baffled.

  5. #5
    PBN User Drew's Avatar
    Join Date
    Jun 2014
    Location
    Long Island new york
    Posts
    419
    Hydrosteam, velocity, fountain


    Ignore User
    Way I see it, you got one slow pump lol

  6. #6
    PBN Charter Member
    Join Date
    Nov 2013
    Location
    New England
    Posts
    57

    Ignore User
    Quote Originally Posted by Drew View Post
    Way I see it, you got one slow pump lol
    I can't imagine that the other pump being slow is the issue...but it could be. Its just weird because the fast one is so fast that if you just tap the switch it easily moves 1-2 positions on the indicator while the other one is very manageable.

  7. #7
    PBN Charter Member
    Join Date
    Nov 2013
    Location
    New England
    Posts
    57

    Ignore User
    Quote Originally Posted by Drew View Post
    Way I see it, you got one slow pump lol
    I can't imagine that the other pump being slow is the issue...but it could be. Its just weird because the fast one is so fast that if you just tap the switch it easily moves 1-2 positions on the indicator while the other one is very manageable.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •